
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20190217000244
template: 
currentrequest: /apps/pbcs.dll/article?avis=IP&date=20190216&category=NEWS&lopenr=190219711&Ref=AR
currentrequestunmodified: /news/20190216/list-of-events-for-week-of-feb-17-2019-in-central-illinois
@templatetype: /apps/pbcs.dll/article?avis=IP&date=20190216&category=NEWS&lopenr=190219711&Ref=AR
@pagetype: article
app version: 2.0.270
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="Chillicothe Times-Bulletin - Chillicothe, IL" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<!-- Meta Tags - Global Article6 guid: 820B513F-1A01-243F-E053-0100007FDD0B-->
<meta name="description" content="Looking for entertainment in the Peoria area? Here are five things to do this week:1 SUNDAYThe 2019 Wurstfest with Bock Bier dinner hosted by Damenchor will be from noon to 6 p.m. Sunday at the Lindenhof, 7601 N. Harker Drive. Cost is $10/adults and $5/children. For more information, visit www.peoriagermans.net.2 WEDNESDAYThe Greater Peoria League of Women Voters will discuss what's happening on the Peoria arts scene at a Drinks and Dialogue event from 5:30 to 6:30 p.m. at the Lariat Steakhouse," />
<meta property="vf:unique_id" content="siteIP-pub267-820B513F-1A01-243F-E053-0100007FDD0B">
<meta property="fb:app_id" content="194807230575727"/>
<meta property="tout:article:id" content="art-820B513F-1A01-243F-E053-0100007FDD0B-pub267">
<meta property="bt:pubDate" content="20190216T17:19:18Z">
<meta property="bt:modDate" content="20190216T17:19:00Z">
<meta property="bt:author" content="">
	<meta name="twitter:card" content="summary">
		<meta name="twitter:image" content="https://www.chillicothetimesbulletin.com/Global/images/head/nameplate/il-chillicothe_logo.png">
		<meta property="og:image" content="https://www.chillicothetimesbulletin.com/Global/images/head/nameplate/il-chillicothe_logo.png">
<meta name="twitter:title" content="List of events for the week of Feb. 17, 2019, in central Illinois">
<meta name="twitter:description" content="Looking for entertainment in the Peoria area? Here are five things to do this week:1 SUNDAYThe 2019 Wurstfest with Bock Bier dinner hosted by Damenchor will be from noon to 6 p.m. Sunday at the Lindenhof, 7601 N. Harker Drive. Cost is $10/adults and $5/children. For more information, visit www.peoriagermans.net.2 WEDNESDAYThe Greater Peoria League of Women Voters will discuss what's happening on the Peoria arts scene at a Drinks and Dialogue event from 5:30 to 6:30 p.m. at the Lariat Steakhouse,">
<meta property="og:title" content="List of events for the week of Feb. 17, 2019, in central Illinois"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="Looking for entertainment in the Peoria area? Here are five things to do this week:1 SUNDAYThe 2019 Wurstfest with Bock Bier dinner hosted by Damenchor" />
<link rel="canonical" href="https://www.chillicothetimesbulletin.com/news/20190216/list-of-events-for-week-of-feb-17-2019-in-central-illinois"/>
<script type="text/javascript">var dfp_url = "820B513F-1A01-243F-E053-0100007FDD0B";</script>
<link rel="amphtml" href="https://www.chillicothetimesbulletin.com/news/20190216/list-of-events-for-week-of-feb-17-2019-in-central-illinois?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.chillicothetimesbulletin.com/news/20190216/list-of-events-for-week-of-feb-17-2019-in-central-illinois"
	},
    "headline": "List of events for the week of Feb. 17, 2019, in central Illinois",
    "url": "https://www.chillicothetimesbulletin.com/article/20190216/NEWS/190219711",
    "thumbnailUrl": "https://www.chillicothetimesbulletin.com/apps/pbcsi.dll/bilde?Site=IP&Date=20190216&Category=NEWS&ArtNo=190219711&Ref=AR",
    "dateCreated": "20190216T23:19:18Z",
    "datePublished": "20190216T23:19:18Z",
    "dateModified": "20190216T23:19:00Z",
    "publisher": {
       "@type": "Organization",
       "name": "Chillicothe Times-Bulletin - Chillicothe, IL",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.chillicothetimesbulletin.com/Global/images/head/nameplate/il-chillicothe_logo.png"
       }
    },
    "articleSection": "News",
    "keywords": [""],
    "isAccessibleForFree": "False",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	}
  }
</script>

		<title> List of events for the week of Feb. 17, 2019, in central Illinois - News - Chillicothe Times-Bulletin - Chillicothe, IL - Chillicothe, IL</title>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900">
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css">
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.270/default.min.css" type="text/css" />
		<style type="text/css">
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
    /*==== ARTICLE ======*/
    	.ad-300x150{
	    	width: 300px;
	    	max-height: 150px;
    	}
    	.adInject{
	    	clear:both;
    	}
    	.articleInjectAd{
	    	display: none;
    	}
    	.native-injected{
	    	height: 0px;
    	}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	/* Buzz widget */
    	#gh-slider-buzz > div > div > figure > a > div.image.unveil-loaded{
			min-height: 112px;
			box-shadow: 0px 0px 5px 0px rgba(50, 50, 50, 0.75);
			border-radius: 2px;
    	}
    	#gh-slider-buzz{
    		font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
    	}
    	#gh-slider-buzz h3 > span{
    		font-weight: bold;
			font-size: 14.4px;
			color:rgb(68, 68, 68);
			text-decoration-color:rgb(68, 68, 68);
			line-height: 16px;
    	}
    	#gh-slider-buzz h3 > span:hover{
			text-decoration: underline;
    	}
    	#gh-slider-buzz .dateline{
			font-size: 10px;
			color:rgb(153, 153, 153);
			text-decoration-color:rgb(153, 153, 153);
    	}
    	#gh-slider-buzz .gh-slider-caption h3{
	    	max-height: 500px;
    	}
    	#gh-slider-buzz div.nophoto > a > h3{
	    	margin-bottom: 5px;
    	}
    	#gh-slider-buzz div.nophoto{
	    	padding:0px;
    	}
    	#gh-slider-buzz span.summary{
	    	font-size: 11px;
		    max-height: 140px;
		    display: block;
		    line-height: 14px;
		    overflow: hidden;
    	}
    	#gh-slider-buzz .slick-slider,#buzz-widget-mobile .section-ribbon,#buzz-widget .section-ribbon{
	    	margin-bottom: 0px;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="//cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<!--[if lte IE 9]>
			<script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
			
					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.chillicothetimesbulletin.com/news" target="_top">News</a></li><li><a href="https://www.chillicothetimesbulletin.com/sports" target="_top">Sports</a></li><li><a href="https://www.chillicothetimesbulletin.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.chillicothetimesbulletin.com/lifestyle" target="_top">Life</a></li><li><a href="https://www.chillicothetimesbulletin.com/obituaries" target="_top">Obituaries</a></li><li><a href="https://www.chillicothetimesbulletin.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.chillicothetimesbulletin.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.chillicothetimesbulletin.com/homes" target="_top">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/ilpeo" target="_blank">Classifieds</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.chillicothetimesbulletin.com/subscribe?g2i_source=chillicothetimesbulletin.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<script type="text/javascript">
	function searchArchive(archval){
		if(archval == 'archive'){
			document.location.href = 'http://nl.newsbank.com/nl-search/we/Archives?p_product=CBIL&p_theme=gatehouse&p_action=keyword';
		}else{
			return false;
		}
	}
</script>
<div class="input-group-btn">
	<button type="button" class="btn btn-default dropdown-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="caret"></span></button>
	<ul class="dropdown-menu" id="searchparam_dd">
		<li data-type="site" class="selected">Site</li>
<li data-type="archive">Archive</li>
	</ul>
</div><!-- /btn-group -->
<script>
$(document).on('click', '#searchparam_dd li', function() {
	searchArchive($(this).data('type'));
});
</script>
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.chillicothetimesbulletin.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.chillicothetimesbulletin.com">
							<img class="mainheadnameplate" src="https://www.chillicothetimesbulletin.com/Global/images/head/nameplate/il-chillicothe_logo.png"  alt="Chillicothe Times-Bulletin - Chillicothe, IL" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.chillicothetimesbulletin.com/subscribe?g2i_source=chillicothetimesbulletin.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.chillicothetimesbulletin.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.chillicothetimesbulletin.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>

				<div class="ad ad-billboard text-center" id="baseLeaderboard" data-size-mapping="baseLeaderboard"></div>
				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20190216171918">
	<div class="inner">
		<h1 class="headline">List of events for the week of Feb. 17, 2019, in central Illinois</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			<div class="article-body">
				<span class="byline-item">
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Saturday</h3>
							<span class="article-meta-date">Feb&nbsp;16,&nbsp;2019&nbsp;at&nbsp;5:19&nbsp;PM</span>
							<span class="article-meta-updated"></span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p><p>Looking for entertainment in the Peoria area? Here are five things to do this week:</p><p>1 SUNDAY</p><p>The 2019 Wurstfest with Bock Bier dinner hosted by Damenchor will be from noon to 6 p.m. Sunday at the Lindenhof, 7601 N. Harker Drive. Cost is $10/adults and $5/children. For more information, visit www.peoriagermans.net.</p><p>2 WEDNESDAY</p><p>The Greater Peoria League of Women Voters will discuss what's happening on the Peoria arts scene at a Drinks and Dialogue event from 5:30 to 6:30 p.m. at the Lariat Steakhouse, 2232 W. Glen Ave. Leading the discussion will be Eileen and Doug Leunig, local artists and co-founders of the Big Picture, along with Jenn Gordon, executive director of ArtsPartners.</p><p>3 FRIDAY</p><p>The Home Builders Association of Greater Peoria&#x2019;s Spring Home Show opens from 4 to 9 p.m. at the Peoria Civic Center Exhibit Hall. The event continues through Feb. 24. Admission is $7 for adults, $3.50 for seniors and free for youth younger than 18.</p><p>4 SATURDAY</p><p>Cabin Fever with Jammsammich will be from 7 to 11 p.m. at Five Points Washington, 360 N. Wilmor Road, Washington. Tickets are $20 per person or $180 for a table of eight. Call 444-8222, Ext. 42.</p><p>5 SATURDAY</p><p>Check out the live hockey action as the Peoria Rivermen take on the Roanoke Rail Yard Dogs at 7:15 p.m. at Carver Arena. It's Hockey Fights Cancer Night featuring special jerseys worn by the Rivermen. A Special Love Your Melon ticket package, which includes a special limited edition Peoria Rivermen Love Your Melon beanie, premium ice level ticket and post-game on ice group photo with the Rivermen players, is available for $39 online at www.Rivermen.net.</p><p>SUNDAY February 17<br/></p><p>Afternoon of music<br/></p><p>Anne Hills will perform as part of the Music in the McKenzie series from 2 to 4 p.m. at the Peoria Public Library's North Branch, 3001 W. Grand Parkway. Admission is free.</p><p>Broadway &amp; opera</p><p>Broadway Lights and Opera Stars, part of the Music Scholarship Concert Series, will be presented at 3 p.m. at Bradley University&#x2019;s Dingeldine Music Center, 1417 W. Barker Ave. Admission is $10 for adults and free for students.</p><p>Jazzy tunes</p><p>The Central Illinois Jazz Society House Band will perform at 6 p.m. followed by Disorganizer at 7:15 p.m. at the Trailside Event Center, 4416 N. Prospect Road, Peoria Heights. Admission is $6 for CIJS members, $8 for nonmembers and free for students.</p><p>MONDAY February 18<br/></p><p>Free tax help</p><p>Metec Resource Center, 2605 W. Krause St., will be open for free income tax preparation from 2 to 6 p.m. For more information, call 676-3832.</p><p>TUESDAY February 19<br/></p><p>Medicare program</p><p>"Medicare Made Clear," a free educational event focusing on Medicare choices, will be offered at 6 p.m. at the Peoria Public Library's Lakeview Branch, 1137 W. Lake Ave.</p><p>Military officers meet</p><p>The Peoria area joint chapters meeting of the Military Officers Association and the Reserve Officers Association will meet at 6:30 p.m. at the Lariat Steakhouse. Social time begins at 6 p.m. The program will be &#x201c;Putin's World View," presented by Angela Weck, associate professor at Bradley University specializing in Russia and director of the Peoria World Affairs Council.</p><p>WEDNESDAY February 20<br/></p><p>Women&#x2019;s brunch</p><p>A women's brunch, sponsored by Peoria Women&#x2019;s Connection, will be from 9:30 to 11 a.m. at Mount Hawley Country Club, 7724 N. Knoxville. Jackie Gillam of Her Majesty's English Tea Room in Dunlap will present the special feature, "Romance in All Our Hearts." Guest speaker Shirley Wheatley will present &#x201c;Cubs of Life.&#x201d; Tickets are $19. Reservations are due Sunday by emailing peoriawc@gmail.com or by calling 688-7477.</p><p>Master gardeners</p><p>Peoria County Master Gardeners will meet at 1 p.m. at the Peoria Extension Office, 4810 N. Sheridan Road. Social time begins at 12:30 p.m. The educational program will feature Master Gardener May Bach speaking on "Vegetable Gardening in Raised Beds and Containers." The membership meeting will follow at 2 p.m.</p><p>Black History Month film<br/></p><p>The Black History Month Film Festival will feature a free showing of "Belle" from 3 to 5 p.m. at the Peoria Public Library's Main Branch, 107 NE Monroe St.</p><p>ICC hoops</p><p>The Illinois Central College women's basketball team will host John Wood Community College at 5:30 p.m. at the CougarPlex on the East Peoria campus. The men's teams for both schools will then face off at 7:30 p.m.</p><p>THURSDAY February 21<br/></p><p>At the library</p><p>The Third Thursday Film Fest: A Year of Musicals will feature a free showing of the 1961 film &#x201c;West Side Story&#x201d; from 2 to 4:30 p.m. at the Peoria Public Library&#x2019;s North Branch, 3001 W. Grand Parkway. Admission is free. Bring a snack.</p><p>Better sleep</p><p>The free program, "Better Sleep, Better Shape Inside and Out," will be offered from 6:30 to 7:30 p.m. at Dunlap Public Library, 302 S. First St., Dunlap. Learn valuable tips for better quality sleep and family life.</p><p>Support for mental illness</p><p>The National Alliance on Mental Illness will offer support group meetings from 7 to 8:30 p.m. at Poplar Hall on Illinois Central College&#x2019;s Peoria Campus, 5407 N. University St. Connections, for individuals living with mental illness, meets in Room 131. Family and friends of people living with mental illness meet in Room 132.</p><p>Bradley talent</p><p>The Bradley Chorale Talent Show will be at 7:30 p.m. at Dingeldine Music Center, 1417 W. Barker Ave. Admission is $5.</p><p>FRIDAY February 22<br/></p><p>Live music</p><p>The NikBeats will perform during Live at the Five Spot from 5:30 to 7:30 p.m. at the Contemporary Art Center of Peoria, 305 SW Water St. Admission is $8 for members and $12 for the public.</p><p>Lady Braves</p><p>The Bradley University women's basketball team will host Illinois State at 7 p.m. at the Renaissance Coliseum. Tickets are $8.</p><p>Icy action</p><p>The Peoria Rivermen will host the Roanoke Rail Yard Dogs at 7:15 p.m. at Carver Arena. It's Ghostbusters Night.</p><p>SATURDAY February 23<br/></p><p>Free tax help</p><p>Metec Resource Center, 2605 W. Krause St., will be open for free income tax preparation from 9 a.m. to 1 p.m. For more information, call 676-3832.</p><p>Bradley hoops<br/></p><p>The Bradley University men's basketball team will host Evansville at 1 p.m. at Carver Arena.</p><p>Young artists</p><p>The final round of the Peoria Symphony Guild&#x2019;s Young Artist Competition will be open to the public at 1 p.m. at Illinois Central College's Lecture/Recital Hall on the East Peoria Campus.</p><p>Oscars pre-party</p><p>An Oscar Awards Pre-Party for ages 14 and older will be from 3 to 4 p.m. at the Peoria Public Library's McClure Branch, 315 W. McClure Ave. There will be Oscars trivia, refreshments, other themed games and a craft. Come dressed as your favorite Oscars-related movie character for a chance to win a gift card.</p><p>Mountain dulcimer concert</p><p>A Mountain Dulcimer Concert will be presented by Heirloom Folk Art School at 7 p.m. at Shore Acres Park, 100 Park Blvd., Chillicothe, as part of the 9th annual Illinois Mountain Dulcimer Weekend. Concert tickets are $10 for adults and free for children ages 11 and younger. For more information, visit www.heirloomfas.com/classes-1/ or call 253-6678.</p><p>For grins</p><p>Comedian Sebastian Maniscalco will perform twice, at 7 and 9:30 p.m., at the Civic Center Theater. Tickets are $42.75 and $62.75.</p><p>Compiled by JENNIFER HOWARD-ADLER </p><p>of the Journal Star</p></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.chillicothetimesbulletin.com/subscribe?g2i_source=chillicothetimesbulletin.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
					<h2>Sign up for daily e-mails</h2>
					<a href="http://myprofile.chillicothetimesbulletin.com/">
						<button type="button" class="btn btn-subscribe">
							Sign up
						</button>
					</a>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://myprofile.chillicothetimesbulletin.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_CTB" target="_top">My Profile</a></li><li><a href="http://nl.newsbank.com/nl-search/we/Archives?p_product=CBIL&p_theme=gatehouse&p_action=keyword" target="_blank">Archives</a></li><li><a href="https://www.chillicothetimesbulletin.com/contact" target="_blank">Contact Us</a></li><li><a href="http://chillicothetimesbulletin.mycapture.com/mycapture/index.asp" target="_blank">Photo Reprints</a></li><li><a href="http://files.gatehousemedia.com/upload/files/home/ghm_pubs/GH_ClassifiedAdForm_12-13.pdf" target="_blank">Classified Advertising Form</a></li><li><a href="http://www.marketingwiththetimes.com" target="_blank">For Advertising</a></li><li><a href="https://www.chillicothetimesbulletin.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill</a></li></ul></div><div class="footer-col"><h4>Market Place<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://www.chillicothetimesbulletin.com/section/cars" target="_blank">Cars</a></li><li><a href="http://lakemedia.mo.newsmemory.com/specials_page2.php" target="_blank">Boats Magazine</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/ilpeo" target="_blank">Classifieds</a></li><li><a href="https://www.chillicothetimesbulletin.com/section/?template=radarfrog" target="_blank">Coupons</a></li></ul></div><div class="footer-col"><h4>Community Info<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.ci.chillicothe.il.us" target="_blank">City of Chillicothe</a></li><li><a href="http://www.ivcschools.com" target="_blank">Illinois Valley Central District 321 Schools</a></li><li><a href="http://www.chillicothechamber.com" target="_blank">Chillicothe Chamber of Commerce</a></li><li><a href="http://www.chillicothepubliclibrary.org" target="_blank">Chillicothe Public Library District</a></li><li><a href="http://www.chillicotheparkdistrict.org/CPD/Home.html" target="_blank">Chillicothe Park District</a></li><li><a href="http://www.chillicothehistorical.org" target="_blank">Chillicothe Historical Society</a></li></ul></div><div class="footer-col"><h4>Communities<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.mortontimesnews.com" target="_blank">Morton</a></li><li><a href="http://www.eastpeoriatimescourier.com" target="_blank">East Peoria</a></li><li><a href="http://www.Washingtontimesreporter.com" target="_blank">Washington</a></li><li><a href="http://www.Woodfordtimes.com" target="_blank">Woodford County</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=IP&date=20190216&category=NEWS&lopenr=190219711&Ref=AR -->
			<div id="footer-main-copyright">
											<p id="footer-copyrightInfo">&copy; Copyright 2006-2019 <a href="http://www.gatehousemedia.com/about-us/" target="_blank">GateHouse Media, LLC.</a> All rights reserved&nbsp;&nbsp;&bull;&nbsp;&nbsp;GateHouse News</p>
							<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
							<br />Chillicothe Times-Bulletin - Chillicothe, IL  ~ PO Box 9426, Peoria, IL 61612-9426 ~ <a href="http://www.gatehousemedia.com/privacy-policy/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gatehousemedia.com/terms_of_use/" target="_blank">Terms Of Service</a></p>
							<script>document.getElementById('footer-main-copyright').getElementsByTagName('p')[1].innerHTML += '<a href="/ownership"><img id="footer-main-gh-logo" src="//cdn.gatehousemedia.com/gh-sites/global/images/logo/ghlogo_horizontal.png" alt="Gatehouse Media Logo"></a>'</script>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.chillicothetimesbulletin.com/subscribe?g2i_source=chillicothetimesbulletin.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.chillicothetimesbulletin.com" target="_top">Home</a></li><li><a href="https://www.chillicothetimesbulletin.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"3468"><a href="https://www.chillicothetimesbulletin.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"3469"><a href="https://www.chillicothetimesbulletin.com/news/court-news" target="_top">Court News</a></li><li id="navLink-TEST-"3470"><a href="https://www.chillicothetimesbulletin.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"3471"><a href="https://www.chillicothetimesbulletin.com/news/police-fire" target="_top">Police & Fire</a></li><li id="navLink-TEST-"3472"><a href="https://www.chillicothetimesbulletin.com/news/shareable" target="_top">Shareable</a></li><li id="navLink-TEST-"3473"><a href="https://www.chillicothetimesbulletin.com/news/state-news" target="_top">State News</a></li><li id="navLink-TEST-"34533"><a href="http://elections.gatehousemedia.com/chillicothetimesbulletin/todaystopics/" target="_blank">Election 2016</a></li></ul></li><li><a href="https://www.chillicothetimesbulletin.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"3476"><a href="https://www.chillicothetimesbulletin.com/sports/high-school" target="_top">High School</a></li></ul></li><li><a href="https://www.chillicothetimesbulletin.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"3479"><a href="https://www.chillicothetimesbulletin.com/entertainment/books" target="_top">Books</a></li><li id="navLink-TEST-"3480"><a href="https://www.chillicothetimesbulletin.com/entertainment/celebrity-news" target="_top">Celebrity News</a></li><li id="navLink-TEST-"3481"><a href="https://www.chillicothetimesbulletin.com/entertainment/movies" target="_top">Movies</a></li><li id="navLink-TEST-"3482"><a href="https://www.chillicothetimesbulletin.com/entertainment/music" target="_top">Music</a></li><li id="navLink-TEST-"3457"><a href="https://www.chillicothetimesbulletin.com/entertainment/tv-guide" target="_top">TV Guide</a></li><li id="navLink-TEST-"38380"><a href="https://www.chillicothetimesbulletin.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.chillicothetimesbulletin.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52227"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li><li id="navLink-TEST-"3486"><a href="https://www.chillicothetimesbulletin.com/lifestyle/boomers" target="_top">Boomers</a></li><li id="navLink-TEST-"3487"><a href="https://www.chillicothetimesbulletin.com/lifestyle/faith" target="_top">Faith</a></li><li id="navLink-TEST-"3488"><a href="https://www.chillicothetimesbulletin.com/lifestyle/family" target="_top">Family</a></li><li id="navLink-TEST-"3489"><a href="https://www.chillicothetimesbulletin.com/lifestyle/food" target="_top">Food</a></li><li id="navLink-TEST-"3490"><a href="https://www.chillicothetimesbulletin.com/lifestyle/health" target="_top">Health</a></li><li id="navLink-TEST-"3491"><a href="https://www.chillicothetimesbulletin.com/lifestyle/home-garden" target="_top">Home & Garden</a></li><li id="navLink-TEST-"3492"><a href="https://www.chillicothetimesbulletin.com/lifestyle/pets" target="_top">Pets</a></li><li id="navLink-TEST-"3493"><a href="https://www.chillicothetimesbulletin.com/lifestyle/travel" target="_top">Travel</a></li></ul></li><li><a href="https://www.chillicothetimesbulletin.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"3496"><a href="https://www.chillicothetimesbulletin.com/opinion/four-corners" target="_top">Four Corners</a></li><li id="navLink-TEST-"3497"><a href="https://www.chillicothetimesbulletin.com/opinion/columns" target="_top">Columns</a></li><li id="navLink-TEST-"3498"><a href="https://www.chillicothetimesbulletin.com/opinion/editorials" target="_top">Editorials</a></li><li id="navLink-TEST-"3499"><a href="https://www.chillicothetimesbulletin.com/opinion/letters" target="_top">Letters</a></li></ul></li><li><a href="https://www.chillicothetimesbulletin.com/business-news" target="_top">Business</a></li><li><a href="https://www.chillicothetimesbulletin.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.chillicothetimesbulletin.com/photos" target="_top">Photos</a></li><li><a href="https://www.chillicothetimesbulletin.com/videos" target="_top">Videos</a></li><li><a href="https://www.chillicothetimesbulletin.com/calendar" target="_top">Calendar</a></li><li><a href="http://games.chillicothetimesbulletin.com" target="_top">Games</a></li><li><a href="https://www.chillicothetimesbulletin.com/contests" target="_top">Contests</a></li><li><a href="http://specialsections.mortontimesnews.com/peoria-times-observer/special-sections" target="_top">Special Sections</a></li><li><a href="https://www.chillicothetimesbulletin.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.chillicothetimesbulletin.com/submit" target="_top">Submit your news</a></li><li><a href="https://www.chillicothetimesbulletin.com/section/promoted//?prx_adpz=2305" target="_top">From Our Advertisers</a></li><li><a href="https://www.chillicothetimesbulletin.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.chillicothetimesbulletin.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_CTB" target="_top">My Profile</a></li><li><a href="https://www.chillicothetimesbulletin.com/subscribe" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://www.marketplaceadsonline.com/marketplace/ilpeo" target="_blank">Classifieds</a></li><li><a href="https://www.chillicothetimesbulletin.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.chillicothetimesbulletin.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.chillicothetimesbulletin.com/homes" target="_top">Homes</a></li><li><a href="https://www.chillicothetimesbulletin.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill</a></li><li><a href="http://chillicothetimesbulletin.thrivehive.com/" target="_blank">Digital Marketing Services</a></li><li><a href="http://timesnewspapers.mortontimesnews.com/ads" target="_blank">FindnSave</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:ctb@timestoday.com">Feedback</a>
		</li>
		<li>
			<a href="/ownership">Ownership</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/terms_of_use/">Terms of Use</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/privacy-policy/">Privacy Policy</a>
		</li>		
		<li>
			<a href="http://www.gatehousemedia.com/our-markets/">GateHouse Media Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.chillicothetimesbulletin.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/pages/Chillicothe-Times-Bulletin/253020456840""
								target="_blank"
								title="Chillicothe Times-Bulletin - Chillicothe, IL Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="/section/feed"
								target="_blank"
								title="Chillicothe Times-Bulletin - Chillicothe, IL RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.chillicothetimesbulletin.com/contact"
								title="Contact Chillicothe Times-Bulletin - Chillicothe, IL">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
        <a href="http://chillicothetimesbulletin.com/subscribe" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.chillicothetimesbulletin.com/apps/pbcs.dll/article?avis=IP&date=20190216&category=NEWS&lopenr=190219711&Ref=AR"}'>
            Learn More
        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.270/app.min.js"></script>
		<script async src="//cdn.gatehousemedia.com/assets/2.0.270/confiant.min.js"></script>
<script>!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
		<script>
		function __gh__init() {
			var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		__gh__init();
		</script>
		<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1"></script>

		
<!--currenttimestamp: 2019-02-17&nbsp;00:02:44-->
	</body>
</html>